Issue
Users on the latest version of macOS who are using CloverDX Designer to log in to their CloverDX Server 7.0 are experiencing issues with the log-in. The log-in process does not complete – the Server is able to authenticate with the identity provided but then redirects to the Server’s home screen instead of completing the log-in process in the Designer.
Note that the SSO log-in to Server Console, Business Tools or Data Apps is not affected by this issue – only log-ins from the Designer are affected.
Cause
The issue is caused by recent update of macOS and Safari browser. The new version enforces stricter cookie and privacy rules with regards to the log-in request headers. CloverDX Designer uses additional header attributes for each session, and it seems that these attributes are lost during the redirect needed for the SAML log-in flow.
Workarounds
Until a permanent solution is released, users on macOS who are having this issue can use the following workaround:
Use username and password for authentication
Instead of SSO, use username and password authentication to log-in to the Server. This requires changes in the Server configuration, and it can be done selectively just for the users who are having the issue (i.e., users on other platforms can still use SSO). See CloverDX Administration guide for more information about how to switch user from SAML domain (which allows for SSO) to clover domain (which does not use SSO and uses built-in account management).
Switching the domain will not change user permissions with regards to sandboxes or other parts of CloverDX and as such it is a safe temporary workaround to apply in this case.
Resolution
CloverDX is actively investigating this issue and working on a fix resolving this issue for macOS users. The fix will be published as a new version of CloverDX platform as soon as it is ready.
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More help needed?
If you require further assistance when switching authentication methods or if you have any further questions, please contact CloverDX Support via email at support@cloverdx.com or via the Support Portal at https://support.cloverdx.com.
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